Xen sur serveur OVH SP-2011

ATTENTION : Cet article à plus de 7 années, il se peut que les infos soient obsolètes ou à adapter aux dernières versions des logiciels.

J’ai récement commandé un serveur SuperPlan 2001 Best Of chez OV. Mon besoins étant de mettre en place plusieurs serveurs pour séparer les services.

J’ai donc commandé le serveur, je l’ai reformaté selon mes besoins et installé l’hyperviseur Xen suivant la méthode suivante : http://blog.cheramy.name/2010/10/17/installation-de-xen-4-sur-une-debian-squeeze/

Pas de problèmes particuliers sur l’installation en vérifiant bien que grub2 était paramétré pour démarrer l’hyperviseur et le bon kernel.

Cependant au boot aucuns résultats, le serveur était inaccessible. Après quelques tests avec le vKVM d’OVH je me rendais bien compte que le serveur démarrait correctement l’hyperviseur et chargeait bien le noyau Xen 2.6.32-5-xen-amd64 mais impossible d’avoir du réseau.

Après quelques tests, je me suis aperçu que le drivers pour la carte réseau de ce serveur – Intel Corporation 82579V Gigabit Network – n’était pas disponible pour cette version du noyau, ni même en module.

Il faut donc compiler ce module. On va donc dans un premier temps mettre en place les outils nécessaires :

# apt-get install build-essential linux-headers-2.6-xen-amd64

 

On récupère ensuite le code du drivers :

# cd /usr/src
# wget http://freefr.dl.sourceforge.net/project/e1000/e1000e%20stable/1.4.4/e1000e-1.4.4.tar.gz
# tar xvjf e1000e-1.4.4.tar.gz
# cd e1000e-1.4.4/src
# BUILD_KERNEL=2.6.32-5-xen-amd64 make install

 

J’ai du forcer le chargement du module en l’ajoutant dans le fichier /etc/modules :

e1000e

 

Et voilà un beau serveur tout neuf qui démarre maintenant correctement avec un accès réseau, c’est quand même plus sympa pour administrer à distance.

Leave a Comment

Your email address will not be published.